Not able to run "nengo" command!

After installing Nengo and trying to run it using the “nengo” command on the Anaconda prompt, I am getting this error:
OSError: [WinError 10013] An attempt was made to access a socket in a way forbidden by its access permissions
anyone can help?

Hi @msbouanane, and welcome to the Nengo forums!

I’ve not seen this error before, and a quick search reveals there may be several issues causing this.
It may be that the default port Nengo is trying to open (to run the GUI) is already in use by another process. To get around this, can you try doing:

nengo --port 8888

and see if that fixes the issue? Note that port 8888 is just an example, you can use any number from 8500 - 65535 as the port number.

It could also be that your antivirus or firewall is blocking Nengo from creating a port to use. If using a custom port (using the --port command from above) doesn’t work, can you try temporarily disabling your firewall and then running the Nengo command again? If that works, we can then go through the steps of adding a firewall rule for Nengo.

1 Like

Thank you very much! I tried changing the port and it worked!