Nengo loihi exception


When I try to run a simple nengo model on the loihi chip using the intel cloud I’m getting an exception:

/homes/fandavid/.virtualenvs/nengo-loihi/lib/python3.5/site-packages/nengo_loihi/ UserWarning: Intercepts are larger than intercept limit (0.95). High intercept values cause issues when discretizing the model for running on Loihi.
  "the model for running on Loihi." % intercept_limit)
/homes/fandavid/.virtualenvs/nengo-loihi/lib/python3.5/site-packages/nengo_loihi/ UserWarning: Seed will be ignored when running on Loihi
  warnings.warn("Seed will be ignored when running on Loihi")
Traceback (most recent call last):
  File "", line 27, in <module>
  File "/homes/fandavid/.virtualenvs/nengo-loihi/lib/python3.5/site-packages/nengo_loihi/", line 385, in run
  File "/homes/fandavid/.virtualenvs/nengo-loihi/lib/python3.5/site-packages/nengo_loihi/", line 426, in run_steps
  File "/homes/fandavid/.virtualenvs/nengo-loihi/lib/python3.5/site-packages/nengo_loihi/", line 534, in create_io_snip
    template = env.get_template("nengo_io.c.template")
  File "/homes/fandavid/.virtualenvs/nengo-loihi/lib/python3.5/site-packages/jinja2/", line 830, in get_template
    return self._load_template(name, self.make_globals(globals))
  File "/homes/fandavid/.virtualenvs/nengo-loihi/lib/python3.5/site-packages/jinja2/", line 804, in _load_template
    template = self.loader.load(self, name, globals)
  File "/homes/fandavid/.virtualenvs/nengo-loihi/lib/python3.5/site-packages/jinja2/", line 113, in load
    source, filename, uptodate = self.get_source(environment, name)
  File "/homes/fandavid/.virtualenvs/nengo-loihi/lib/python3.5/site-packages/jinja2/", line 187, in get_source
    raise TemplateNotFound(template)
jinja2.exceptions.TemplateNotFound: nengo_io.c.template

Is my environment not properly setup correctly?

My installed packages are:

nengo           2.8.0
nengo-loihi     0.4.0.dev0
nengo-spa       0.6.0
networkx        2.2
numpy           1.14.3
nxsdk           0.7

I tried with both version 0.3.0 and 0.4.0.dev0 with the same result.

No, you’re not doing anything wrong, that’s a bug on our end (it’ll be fixed in the next release).

In the meantime, if you perform a developer installation (, then everything should work OK.

Yep, that seemed to do it.