Nengo_gui has stopped running upon start


#1

Hi,
when I start the nengo_gui I immediately get an error message that the nengo guy has stopped running.
I’m using a mac. what can I do to fix this?

thanks,
s


#2

Could you post the full error message? It might be something unrelated, but one possibility is that the GUI will auto-shutdown if there are no browser windows open with the GUI open. Normally when you do nengo a browser window will pop open, but if something goes wrong with that process then the GUI could automatically shutdown without giving you the chance to open a browser window yourself.

You can disable the auto-shutdown by opening Nengo with

nengo --auto-shutdown 0

Does that fix your problem? If not, what is the full error message?


#3

Hi Trevor,

thank you for your help.
Unfortunatley your little trick didn’t help.
Here is the complete error message I get in the Terminal window.

Starting nengo server at http://localhost:8081
ERROR:nengo_gui.guibackend:Error during websocket communication.
Traceback (most recent call last):
  File "/Users/sebastian/anaconda/lib/python3.6/site-packages/nengo_gui/guibackend.py", line 223, in ws_default
    msg = self.ws.read_frame()
  File "/Users/sebastian/anaconda/lib/python3.6/site-packages/nengo_gui/server.py", line 363, in read_frame
    self._read()
  File "/Users/sebastian/anaconda/lib/python3.6/site-packages/nengo_gui/server.py", line 344, in _read
    self._buf = self._buf + bytearray(self.socket.recv(512))
ConnectionResetError: [Errno 54] Connection reset by peer

#4

Hm, this is a difficult to debug issue because it could be caused by a lot of networking issues specific to your environment.

Have you ever gotten the Nengo GUI to run successfully? Has anything significant changed since the last time you got Nengo to run successfully?

Can you try running the following from the command line:

python -m http.server

and then navigating to http://localhost:8000/ ? This will help us track down the issue to see if it’s related to your environment or Nengo specifically.


#5

Are you using Safari? There is a known bug with Safari. You can try to use a different browser or installing the master branch for GitHub.

Also see #898.


#6

Hi Trevor,

sorry for my delay.
I never succeeded in running the Nengo GUI successfully.

I ran the command you suggested and navigated to the localhost:8000.
this is the response in the command line:
sh-3.2# python -m http.server
Serving HTTP on 0.0.0.0 port 8000 (http://0.0.0.0:8000/) …
127.0.0.1 - - [16/Oct/2017 23:10:44] “GET / HTTP/1.1” 200 -

Does that help?
Anything else I could try?

Thanks,
Sebastian


#7

Can you tell us which browser you are using?


#8

Hi Jan,
I’m Using safari.


#9

This may be because of an issue that we recently fixed relating to Safari. We just released a version of the GUI with this fix, so can you try doing

pip install --upgrade nengo_gui

and see if it works now?


#10

Hi,

wonderful, it works!
thank you so much for your help.
Cheers,
-Sebastian


#11

Great, glad to hear it!