Jupyterlab-nengo 0.1.0 released


#1

I am excited to announce the release of jupyterlab-nengo.

What is jupyterlab-nengo?

The jupyterlab-nengo extension allows to run the Nengo GUI within JupyterLab. That means you get all the amazing JupyterLab features such as multiple panes, tabs, code editor, and so on integrated with the Nengo GUI interface.

Note that the JupyterLab extension API is still under active development and thus the jupyterlab-extension might break through JupyterLab updates.

How do I get it?

  1. First you will need the development version of Nengo GUI from GitHub. Example install commands:
git clone https://github.com/nengo/nengo-gui.git
pip install ./nengo-gui
  1. Obviously, you will also need JupyterLab (at least version 0.33).
pip install jupyterlab
  1. Install Node.js with npm.
  2. Activate the Jupyter server extension by putting the following into your ~/.jupyter/jupyter_notebook_config.json file:
{
  "NotebookApp": {
    "nbserver_extensions": {
      "nengo_gui.jupyter": true
    }
  }
}
  1. Install jupyterlab-nengo:
jupyter labextension install @jgosmann/jupyterlab-nengo

How do I use it?

  1. Run JupyterLab: jupyter lab.
  2. You can open the Nengo GUI interface by right clicking on a Python file in the file explorer and choosing Open with / Nengo.

Where can I get help?

You’re already there! If you have an issue upgrading or have any other questions, please post them in this forum.


#2

Jan - Thanks for doing this. I thought I would try it; anticipating some install problems and learning curve.

regarding step 3. my config was
~/.jupyter/nbcinfig/notebook

{
“Cell”: {
“cm_config”: {
“lineNumbers”: true
}
}
}

I changed that to: {
“Cell”: {
“cm_config”: {
“lineNumbers”: true
}
}
}

{
{
“NotebookApp”: {
“nbserver_extensions”: {
“nengo_gui.jupyter”: true
}
}
}

#4. when I entered the … jupyter labextension install … @jgosmann/jupyterlab-nengo

I received the ff:

Errored, use --debug for full output:
ValueError: Please install nodejs 5+ and npm before continuing. nodejs may be installed using conda or directly from the nodejs website.

I am writing this before going to the nodejs website - I will try that now, Otherwise, I am afraid I need explicit directions for these last steps.

Thanks

Howard C_


#3

Yes, it seems that you need to install NodeJS (and NPM, which I believe to be included in NodeJS). I had those installed as part of my development environment, but was not aware that they are required in a production environment too (it is not mentioned in the Jupyter Lab documentation I believe, but it doesn’t surprise me either). I will update the readme when I get the chance.


#4

Hi & thanks …

I did the installs and everything seemed to load. However,
n.b. typing ‘jupyter notebook’ works well as before.

However, typing ‘jupyter lab’ brings up the appropriate files. The .ipynb files still work in python. When I right cliock on the .py files and select to run them with nengo, a large white screen with a smaller white box comes up and nothing else.

? does any code need be added or removed from the old .py files that worked in the non-jupyter gui?

More troubling, when I simply type ‘nengo’ that also brought up the nengo gui before (but not as a jupyter notebook), I know get the error message

from nengo.utils.compat import escape

Import Error: cannot import name ‘escape’


#5

What is your Nengo version? Try to upgrade to the 2.8.0 release.


#6

I guess I was using 2.7. When I upgraded to 2.8, the old nengo gui worked fine. Thanks

However, with jupyter lab I still had the same results. i.e. It seemed to start just fine, the files were displayed all right. When I right clicked on a .py file and selected nengo, a large and smaller white box was displayed, but nothing within them.

the jupyter files are as follows:

.jupyter/lab/workspaces/lab-a51-jupyter or similar and …
.jupyter/nbconfig/notebook.json

I had tried renaming the notebook.json files and moving it to
.jupyter/jupyter_notebook_config.json

when I was still running 2.7.

I could rename and move now if you think that might help.

Thanks


#7

I did what I asked about regarding putting the code into the ~/.jupyter/jupyter_notebook_config.json file and -

it seems to work.
Thanks


#8

When I tried the same install on my computer at work I got the foolowing error:

ValueError: No version of @jgosmann/jupyterlab-nengo could be found that is compatible with the current version of JupyterLab. However, it seems to support a new version of JupyterLab. Consider upgrading JupyterLab.

Conflicting Dependencies:
JupyterLab Extension Package

=0.18.4 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/application
=0.18.4 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/docmanager

I had done a new python install about 6 wks ago after hard drive was reformatted. nengo-gui and jupyter version had been working fine. I did a:

pip install jupyterlab

as instructed

??

Thanks

Howard C


#9

It seems that the JupyterLab version is too old nevertheless. Try to upgrade it with:

pip install -U jupyterlab

#10

works - up and running - thanks